• ChristIsKing.eu has moved to ChristIsKing.cc - see the announcement for more details. If you don't know your password PM a mod on Element or via a temporary account here to confirm your username and email.

ChristIsKing.eu Is Moving To ChristIsKing.cc

soli.deo.gloria

Administrator
Orthodox
Moderator
Heritage
Hello everyone,

We are moving Christ is King forum from the .eu domain to .cc.

This is being done proactively to avoid potential issues down the road as the EU is not exactly friendly regarding freedom of speech.

The .cc TLD is managed by Verisign in the US and they have a good track record for freedom of speech.

The old domain will continue to work for now but please update your bookmarks.

Please let us know if you have any questions or issues relating to the change.

Thanks & God bless. :) ☦️

Warm regards,

Your friendly server admin team
 
Three issues popped up:
1699043753611.png

And then Kaspersky AV gave a warning for an unsecure connection


Finally, my login will not work.
 
Last edited:
Everything should be working as intended now.

Visitors to the old domain .eu will be redirected to the new domain .cc without having to do anything.

If you or someone you know has a problem please clear your cookies and close the browser tab and start over and it should work.

I also had some issues as chrome stubbornly hung on to the old session/cookie and wouldn't let me redirect at first.

Sorry for any troubles and thank you for your patience during these small growing pains. :)
 
I tried visiting christforking.eu for several hours and got this error (stock photo).

I then switched browsers and instead of Brave used Microsoft Edge.

This is probably also the reason why there are so few people online now.

254398-f424fc5670d3b3f6ef8e7ef648df9808.png
 
Last edited:
I tried visiting christforking.eu for several hours and got this error (stock photo).

I then switched browsers and instead of Brave used Microsoft Edge.

This is probably also the reason why there are so few people online now.

254398-f424fc5670d3b3f6ef8e7ef648df9808.png

There is an issue with the setup, addressing...
 
you bet. i'm sorry if anything i did caused a problem. i tested it earlier and it seemed to be working 100% but i think something happened after i went to dinner. i ran through the configs again and it should be all good now. also just a reminder you can get help on matrix/element if the site is down.
 
I am not sure if this is related to the domain change, but I posted two embedded Telegram videos and they are no longer showing properly.
 
I am not sure if this is related to the domain change, but I posted two embedded Telegram videos and they are no longer showing properly.

Media too big and not supported? I would guess that's on Telegram's side.
 
I was unable to get my password to work even though I'm pretty sure it was correct. So I clicked forgot password and sent a reset link but it wouldn't send to my email. So I got a temporary password on Element chat through Cynllo and I was able to log back in.
 
I was getting on and off certificate errors on .cc about a couple of hours ago, but all seems to be fixed now. New domain working for me as expected.
 
Back
Top